powered by Tobias Fuchs

Not logged in. · Lost password · Register

All posts by f.gruber (10)

topic: [gelöst] Kurze Unterbrechungen bei Aufnahme  in the forum: Allgemein Fragen/Probleme Linux
f.gruber #1
Member since Nov 2009 · 10 posts · Location: Bad Schallerbach
Group memberships: Benutzer
Show profile · Link to this post
Subject: Playthrough ausgeschaltet
Ich habe in Audacity unter Bearbeiten / Einstellungen / Aufnahme die Option "Software Playthrough" ausgeschaltet. Nun sind die Unterbrechungen bei der Aufnahme weg.
Gruß
Ferdinand
topic: [gelöst] Kurze Unterbrechungen bei Aufnahme  in the forum: Allgemein Fragen/Probleme Linux
f.gruber #2
Member since Nov 2009 · 10 posts · Location: Bad Schallerbach
Group memberships: Benutzer
Show profile · Link to this post
In reply to post ID 22387
Kann mir denn niemand helfen?

Ich habe schon alles versucht, was mir denkbar vorkommt.
Das Störgeräusch tritt etwa alle 6 Sekunden auf.

Ich habe das Programm "top" parallel laufen lassen und sehe, dass etwa zeitgleich zu den Störgeräüuschen etwas passiert. Aber ich kann nicht wirklich eindeutig erkennen, welche Prozesse da Schuld an diesen Unterbrechungen sein könnten.

Hier die in eine Textdatei umgeleitete Ausgabe von "top":


 5814 root      20   0  176m  58m  10m S      6  2.9   7:02.71 Xorg
 6198 grfe      20   0  402m 118m  35m S      3  5.9   1:18.97 firefox-bin
 6612 grfe      20   0  162m  48m  22m S      2  2.4   0:10.27 konsole
 6046 grfe      20   0  245m  54m  28m S      1  2.7   0:04.39 kwin
 6078 grfe      20   0  347m  72m  36m S      0  3.7   0:07.48 plasma-desktop
    1 root      20   0  2216  740  636 S      0  0.0   0:00.65 init
    2 root      20   0     0    0    0 S      0  0.0   0:00.00 kthreadd
    3 root      20   0     0    0    0 S      0  0.0   0:00.00 ksoftirqd/0 
    6 root      RT   0     0    0    0 S      0  0.0   0:00.00 migration/0
    7 root      -2  19     0    0    0 S      0  0.0   0:00.26 rcuc0
    8 root      RT   0     0    0    0 S      0  0.0   0:00.00 rcun0
    9 root      -2   0     0    0    0 S      0  0.0   0:00.00 rcub0
   10 root      RT   0     0    0    0 S      0  0.0   0:00.00 rcun1
   11 root      -2   0     0    0    0 S      0  0.0   0:00.00 rcub1
   12 root      RT   0     0    0    0 S      0  0.0   0:00.00 watchdog/0
   13 root      RT   0     0    0    0 S      0  0.0   0:00.00 migration/1
   15 root      -2  19     0    0    0 S      0  0.0   0:00.25 rcuc1
   16 root      20   0     0    0    0 S      0  0.0   0:00.00 ksoftirqd/1
   18 root      RT   0     0    0    0 S      0  0.0   0:00.00 watchdog/1
   19 root       0 -20     0    0    0 S      0  0.0   0:00.00 cpuset
   20 root       0 -20     0    0    0 S      0  0.0   0:00.00 khelper
   21 root       0 -20     0    0    0 S      0  0.0   0:00.00 netns
   22 root      20   0     0    0    0 S      0  0.0   0:00.00 sync_supers
   23 root      20   0     0    0    0 S      0  0.0   0:00.00 bdi-default
   24 root       0 -20     0    0    0 S      0  0.0   0:00.00 kintegrityd
   25 root       0 -20     0    0    0 S      0  0.0   0:00.00 kblockd
   26 root       0 -20     0    0    0 S      0  0.0   0:00.00 ata_sff
   27 root      20   0     0    0    0 S      0  0.0   0:00.00 khubd
   28 root       0 -20     0    0    0 S      0  0.0   0:00.00 md
   30 root      20   0     0    0    0 S      0  0.0   0:00.00 khungtaskd
   31 root      20   0     0    0    0 S      0  0.0   0:00.20 kswapd0
   32 root      25   5     0    0    0 S      0  0.0   0:00.00 ksmd
   33 root      39  19     0    0    0 S      0  0.0   0:00.10 khugepaged
   34 root      20   0     0    0    0 S      0  0.0   0:00.00 fsnotify_mark
   35 root       0 -20     0    0    0 S      0  0.0   0:00.00 crypto
   39 root       0 -20     0    0    0 S      0  0.0   0:00.00 kthrotld
   40 root      20   0     0    0    0 S      0  0.0   0:00.00 scsi_eh_0
   41 root      20   0     0    0    0 S      0  0.0   0:00.00 scsi_eh_1
   42 root      20   0     0    0    0 S      0  0.0   0:00.00 kworker/u:1
   44 root      20   0     0    0    0 S      0  0.0   0:00.00 scsi_eh_2
   45 root      20   0     0    0    0 S      0  0.0   0:00.25 scsi_eh_3
   48 root      20   0     0    0    0 S      0  0.0   0:00.00 scsi_eh_4
   49 root      20   0     0    0    0 S      0  0.0   0:00.00 scsi_eh_5
   50 root      20   0     0    0    0 S      0  0.0   0:00.00 kworker/u:5
   52 root       0 -20     0    0    0 S      0  0.0   0:00.00 kpsmoused
   86 root      20   0     0    0    0 S      0  0.0   0:00.00 scsi_eh_6
   87 root      20   0     0    0    0 S      0  0.0   0:00.01 scsi_eh_7
  288 root      20   0     0    0    0 S      0  0.0   0:00.49 kjournald
  294 root      20   0     0    0    0 S      0  0.0   0:00.27 flush-8:0
Gruß
Ferdinand
topic: [gelöst] Kurze Unterbrechungen bei Aufnahme  in the forum: Allgemein Fragen/Probleme Linux
f.gruber #3
Member since Nov 2009 · 10 posts · Location: Bad Schallerbach
Group memberships: Benutzer
Show profile · Link to this post
In reply to post ID 22386
Quote by edgar-rft:
... ob irgend ein anderes Programm versucht Audacity Rechenzeit zu klauen oder versucht gleichzeitig auf die Soundkarte zuzugreifen?

Bisher ist es ja gegangen.

Der Computer ist sicher nicht zu schwach für Audacity:

  Prozessor (CPU):   Intel(R) Core(TM)2 Duo CPU E6750 @ 2.66GHz
  RAM: 2 GB

... Audacity 1.3.1-beta...

Tut mir leid, da hatte ich mich vertan: Die Versionsbezeichnung ist: audacity-1.3.13
Gruß
Ferdinand
This post was edited on 2011-08-24, 22:31 by f.gruber.
topic: [gelöst] Kurze Unterbrechungen bei Aufnahme  in the forum: Allgemein Fragen/Probleme Linux
f.gruber #4
Member since Nov 2009 · 10 posts · Location: Bad Schallerbach
Group memberships: Benutzer
Show profile · Link to this post
Subject: [gelöst] Kurze Unterbrechungen bei Aufnahme
Hallo,
neuerdings habe ich bei der Aufnahme kurze Unterbrechungen verbunden mit einem Knackser. Das tritt so etwa alle 6 Sekunden auf, manchmal auch öfter.
So schaut die WaveForm aus:
[Image: http://members.aon.at/fergru/images/audacity1.png]
Das Problem tritt auch auf, wenn das Aufnahmegerät, ein MiniDiskRecorder, gar nicht angeschlossen ist:
[Image: http://members.aon.at/fergru/images/audacity2.png]

Ich arbeite mit Audacity 1.3.13-beta unter Suse 11.4 mit KDE 4.6
Gruß
Ferdinand
This post was edited 2 times, last on 2011-09-01, 12:32 by f.gruber.
topic: Aufnahme vertikal verschoben  in the forum: Allgemein Generelle Fragen und Anregungen
f.gruber #5
Member since Nov 2009 · 10 posts · Location: Bad Schallerbach
Group memberships: Benutzer
Show profile · Link to this post
Subject: Aufnahme vertikal verschoben
Hallo,
ich habe von einem MiniDisk Recorder was aufgenommen.

Die Waveform ist vertikal etwas verschoben um etwas mehr als 0.1 Einheiten nach oben (weiß leider nicht, welche Maßeinheit das ist).

Ich habe gelesen, dass das von einem Gleichstromanteil in der Aufnahme kommt und dass man das in Audacity mit "Effekte / Gleichspannung entfernen (auf die Nullinie zentrieren)" beheben kann. Das habe ich gemacht. Am Klang merke ich aber eigentlich keinen Unterschied.

Soll ich die Originalversion belassen oder soll man diese Normalisierung durchführen und das Projekt so speichern?

Wie kann ich verhindern, dass diese Verschiebung entsteht?

Gruß
Ferdinand
Gruß
Ferdinand
topic: [gelöst] Aufnahme bricht ab  in the forum: Allgemein Fragen/Probleme Linux
f.gruber #6
Member since Nov 2009 · 10 posts · Location: Bad Schallerbach
Group memberships: Benutzer
Show profile · Link to this post
In reply to post ID 22326
Quote by f.gruber:
... Ich verwende die Version 1.3.12-12.1 unter Suse 11.4 mit KDE 4.6
Ich habe nun die Version 1.3.13-51 installiert.

Damit ist dieses Problem gelöst.
Audacity bricht die Aufnahme nicht mehr ab.
Gruß
Ferdinand
topic: [gelöst] Aufnahme bricht ab  in the forum: Allgemein Fragen/Probleme Linux
f.gruber #7
Member since Nov 2009 · 10 posts · Location: Bad Schallerbach
Group memberships: Benutzer
Show profile · Link to this post
Subject: [gelöst] Aufnahme bricht ab
Hallo,
ich versuche über den Line Eingang von einem MiniDisk Recorder aufzunehmen. Es funktioniert grundsätzlich, doch nach einigen Minuten (meist etwa 4-5 Minuten) bricht die Aufnahme plötzlich ab.

Ich verwende die Version 1.3.12-12.1 unter Suse 11.4 mit KDE 4.6

Gruß
Ferdinand
Gruß
Ferdinand
This post was edited on 2011-08-07, 21:52 by f.gruber.
topic: Aufnahme stoppt nach 0,6 Sekunden  in the forum: Allgemein Fragen/Probleme Linux
f.gruber #8
Member since Nov 2009 · 10 posts · Location: Bad Schallerbach
Group memberships: Benutzer
Show profile · Link to this post
In reply to post ID 18166
Quote by Markus on 2009-11-23, 09:40:
Könnte es sein, dass bei Dir noch ein Soundserver im Hintergrund läuft, z.B. ESD, ARTS oder PulseAudio?
Wie kann ich das feststellen, welche und wieviele Soundserver laufen?
PulseAudio ist installiert, das sehe ich im YAST. Außerdem ist im K-Menü eine Verknüpfung zu PulseAudio Einstellungen.

Wie kann ich einen Soundserver, wie z.B. PulseAudio deaktivieren? Muss ich ihn deinstallieren, ist das sinnvoll?
Gruß
Ferdinand
topic: Aufnahme stoppt nach 0,6 Sekunden  in the forum: Allgemein Fragen/Probleme Linux
f.gruber #9
Member since Nov 2009 · 10 posts · Location: Bad Schallerbach
Group memberships: Benutzer
Show profile · Link to this post
In reply to post ID 18159
Quote by Markus:
Audacity 1.3.5-beta ist uralt. Versuch mal, die aktuelle CVS-Version zu kompilieren und zu installieren.

Danke für den Tipp.
Ich habe jetzt die Version 1.3.9 als rpm heruntergeladen und installiert.

Jetzt funtioniert die Aufnahme tatsächlich - aber nicht perfekt.

Erst nach einigen Versuchen klappt es, d.h. ich muss mindestens zwei Mal auf den roten Aufnahmeknopf und dann auf den Stopp Knopf drücken. Plötzlich läuft es dann. Es kann sein, dass die Aufnahme dann irgendwann einmal abbricht. Ausgiebig getestet habe ich es aber noch nicht.

Gehe ich richtig in der Annahme, dass eine selbst kompilierte Version besser an das System angepasst sein wird?
Gruß
Ferdinand
topic: Aufnahme stoppt nach 0,6 Sekunden  in the forum: Allgemein Fragen/Probleme Linux
f.gruber #10
Member since Nov 2009 · 10 posts · Location: Bad Schallerbach
Group memberships: Benutzer
Show profile · Link to this post
Subject: Aufnahme stoppt nach 0,6 Sekunden
Hallo,
ich versuche mit Audacity über den LineIn Port der Soundkarte Musik von einer MiniDisk aufzunehmen.

Die Aufnahme bricht immer nach 0.6 Sekunden ab. Ich höre dann zwar über die an der Soundcard angeschlossenen Lautsprecher die Wiedergabe der Musik vom MiniDisk Player. Es wird aber nichts aufgenommen.

Habe alle möglichen Einstellungen ausprobiert, aber ohne Erfolg.

Das System ist Suse Linux 11.1, KDE 3.5
Ich habe ALSA als Soundserver eingestellt.
Der Computer ist gut ausgestattet, denke ich: 2 GB RAM, Core 2 DUO Prozessor mit 2,6 MHZ, also daran wird es wohl nicht liegen.

Audacity habe ich mit
nice -15 audacity
gestartet, was aber auch nichts gebracht hat.

Die Audaciy Version ist 1.3.5 beta - YAST hat diese installiert ...

Ich habe zwei Soundkarten, eine onboard und die andere eine Soundblaster PCI Karte. Diese habe ich eingbaut wegen dem Joystick Port, den ich für ein MIDI Keyboard brauche. Ich habe es mit beiden Soundkarten am LinIn Port probiert, es ist bei jeder das gleiche Problem, wie oben geschildert. Es wird also wohl nicht an der Soundkarte liegen ...

Bin alles andere als ein Soundprofi aber mit Linux habe ich schon etwas Erfahrung. Alles, was mit Multimedia zu tun hat, ist mir eher schleierhaft.

Ich bitte dringend um nachsichtige Hilfe.
Gruß
Ferdinand
Close Smaller – Larger + Reply to this post:
Special characters:
Special queries
Go to forum
This board is powered by the Unclassified NewsBoard software, 20110527-dev, © 2003-2011 by Yves Goergen
Current time: 2014-10-21, 15:29:44 (UTC +02:00)