powered by Tobias Fuchs

Nicht angemeldet. · Kennwort vergessen · Registrieren
Forum: AUDACITY 2.X HILFE FORUM GNU/Linux und Unix-oide RSS
Langsamere Wiedergabe
felixed #1
Mitglied seit 05/2015 · 3 Beiträge
Gruppenmitgliedschaften: Benutzer
Profil anzeigen · Link auf diesen Beitrag
Betreff: Langsamere Wiedergabe
Ich arbeite schon seit Jahren mit Audacity. Nach ein paar Konfigurationsproblemen lief alles problemlos. Für meine Zwecke (hauptsächlich Mikrofonaufnahmen und Erstellung von Audio-Sicherheitskopien von Internetquellen) ist das Programm mehr als gut geeignet. Also vollste Zufriedenheit. Bis kürzlich, genauer gesagt letzte Woche.

Das Problem habe ich sowohl auf einem Lenovo G50 mit Ubuntu Trusty als auch auf meinem Desktop (Eigenbau) mit Debian 7 - scheint also nichts mit der Hardware zu tun zu haben.

Aufrnahmen funktionieren wie gewohnt, allerdings sind sie länger als das Original (5-10%) und werden demzufolge verlangsamt wiedergegeben.

Das Problem scheint nicht an Audacity zu liegen, da ich den gleichen Effekt auch mit dem gnome-sound-recorder 3.4.0 habe.

Aufnahmeeingang: pulse Line:0 (gleiches Ergebnis bei default: Line:0)
felixed #2
Mitglied seit 05/2015 · 3 Beiträge
Gruppenmitgliedschaften: Benutzer
Profil anzeigen · Link auf diesen Beitrag
Nachtrag: Sampling mit 48 kHz und Verarbeitung als 44,1 kHz müßte genau diesen Fehler verursachen. Die Umstellung der sampling rate in Audacity (44,1 und 48) lieferte aber das gleiche Ergebnis.

Ein Pulseaudio-Problem? Wenn ja, welche Lösung?

Pulseaudio zu deinstallieren geht nicht, ohne gnome zu deinstallieren, was ich ungern tun würde.
Avatar
Uli Nobbe #3
Benutzertitel: Sprecher
Mitglied seit 03/2012 · 1347 Beiträge · Wohnort: Frankfurt am Main
Gruppenmitgliedschaften: Benutzer
Profil anzeigen · Link auf diesen Beitrag
Antwort auf Beitrag #1
Zitat von felixed:
Das Problem scheint nicht an Audacity zu liegen, da ich den gleichen Effekt auch mit dem gnome-sound-recorder 3.4.0 habe.
Tja, was sagen denn die Linux-Foren dazu, z.B. ubuntuusers?
Ich schreibe Dir diese Antwort auf einem T42 mit Lubuntu. Hier funktioniert Audacity problemlos. Allerdings nutze ich pulse audio nicht, sondern habe bei Aufnahmen mit diesem Laptop immer ein Interface am Start bzw. einen Pocketrecorder.

Probleme mit pulse audio zeigen sich vereinzelt auch mit Skype. Da gibt es irgendeinen Trick, wie mir ein Kollege sagte, aber den habe ich noch nicht drauf. Müsste man mal in den Tiefen von Linux graben.
Auch Audacity kann den guten alten Technikergrundsatz nicht aushebeln:
Shit in - shit out: Qualität entsteht während der Aufnahme, nicht in der Nachbearbeitung!

Aktuelle Version: Audacity 2.1.3
felixed #4
Mitglied seit 05/2015 · 3 Beiträge
Gruppenmitgliedschaften: Benutzer
Profil anzeigen · Link auf diesen Beitrag
Auf forum.ubuntuusers.de bixher keine nützliche Antwort.

von https://wiki.archlinux.org/index.php/PulseAudio/Troublesho… auch ohne Erfolg:

Laggy sound

This issue is due to incorrect buffer sizes. First verify that the variables default-fragments and default-fragment-size-msec are not being set to non default values in the file /etc/pulse/daemon.conf. If the issue is still present, try setting them to the following values:

/etc/pulse/daemon.conf

default-fragments = 5
default-fragment-size-msec = 2

Choppy/distorted sound

This can result from an incorrectly set sample rate. Try the following setting:

/etc/pulse/daemon.conf

default-sample-rate = 48000

and restart the PulseAudio server.
EmilZ #5
Mitglied seit 09/2016 · 2 Beiträge
Gruppenmitgliedschaften: Benutzer
Profil anzeigen · Link auf diesen Beitrag
Hallo,

Ich grabe mal diesen alten Thread aus, weil es eine neue Situation gibt.
In Linux Mint 18 Cinnamon ist dieser Fehler in Puls-Audio offenbar behoben worden, ich habe das gerade ausprobiert.
Ich musste nur den Puls-Lautstärkeregler nachinstallieren, danach hat es auf Anhieb geklappt. Weder Tonhöhe noch Geschwindigkeit wurden verändert.
Meine Audacity Version ist 2.1... Die genaue Nummer habe ich im Moment nicht. Auf alle Fälle ist es die, welche man über die Synaptik Paketverwaltung installiert.

EmilZ
Dieser Beitrag wurde am 21.09.2016, 20:36 von EmilZ verändert.
Schließen Kleiner – Größer + Auf diesen Beitrag antworten:
Prüfcode: VeriCode Gib bitte das Wort aus dem Bild ins folgende Textfeld ein. (Nur die Buchstaben eingeben, Kleinschreibung ist in Ordnung.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Weitere Zeichen:
Gehe zu Forum
This board is powered by the Unclassified NewsBoard software, 20120620-dev, © 2003-2011 by Yves Goergen
Aktuelle Zeit: 20.09.2017, 02:19:19 (UTC +02:00)