powered by Tobias Fuchs

Nicht angemeldet. · Kennwort vergessen · Registrieren
Forum: FEEDBACK UND DISKUSSION Generelle Fragen und Anregungen RSS
FEHLER! Audacity 2.2.0 speichert ab und zu AUP-Datei falsch ab. Irreparabel.
kischjan #1
Mitglied seit 01/2018 · 1 Beitrag
Gruppenmitgliedschaften: Benutzer
Profil anzeigen · Link auf diesen Beitrag
Betreff: FEHLER! Audacity 2.2.0 speichert ab und zu AUP-Datei falsch ab. Irreparabel.
Audacity 2.2.0 hat einen Fehler: Ab und zu kommt es vor, dass beim Speichern der AUP-Datei die File-Namen der Audioblöcke LEER sind, wo normalerweise ein Name eines Audio-Blocks stehen soll.

AUSGANGSSITUATION:
Wir arbeiten mit Schülern an Laptops (Extensa 5635 Win 7-32) mit Audacity 2.2.0, d. h. 4 Klassen mit je 10 Laptops.
Während Laufwerk C mit Timefreeze nach dem Hochfahren immer wieder auf Ausgangszustand gesetzt wird, bleibt das Laufwerk D: (wo alle Zeiger in Audacity draufzeigen und wo alles abgespeichert wird) unangetastet. Das klappt mit allen (!) Programmen, man muss eben die Links im Programm auf "D:" setzen.
Die Schüler haben zunächst Sprachaufnahmen gemacht (geschnitten und verschoben) und dann MP3-Files importiert, geschnitten und verschoben (Radiowerbung).

DAS PROBLEM:
Immer mal wieder kam es vor (10% der Fälle!), dass Audacity offenbar die AUP-Datei falsch abgespeichert hat, heute trat es bei 3 von 10 Laptops auf!
Die Schüler luden ihre gestern bearbeiteten Dateien hoch und bei eben den 3 Laptops erschienen Fehlermeldungen.
Eine Fehlermeldung: "Beim Prüfen der Projektdatei sind Probleme mit dem <sequence> Tag aufgetreten." Man kann es dann sofort schließen oder versuchen, mit Reparaturen aus dem Protokoll fortzufahren (was aber nichts bringt - hier kommt man nicht weiter).
Eine andere Fehlermeldung: Es fehlen Audiodaten-Blockdateien, man hat die drei Optionen "Schließen", "als Stille behandeln" (temporär oder dauerhaft), d. h. dass man sieht, wo die Bausteine auf den Spuren sind, aber sie sind alle leer (eben Stille).
Die Kontrolle (Explorer) zeigt jedoch, dass noch alle Blockdateien KORREKT in dem Ordner XXX_data/e00/d00/... drin sind, z. B. "e0000aa6.au", man kann sie sich mit einem anderen Programm anhören.

Dann habe ich mir die AUP-Datei angeschaut. WOW! Dort, wo die File-Namen der Audio-Blöcke stehen (sollten), sind leere Anführungsstriche. (siehe unten!) Und dann scheinen sich bestimmte Teile auch zu wiederholen.
Ein Hammer-Fehler! Denn man kann somit die AUP-Datei nicht wieder herstellen!
Audacity hat die AUP-Datei falsch abgespeichert.

Ich habe unten zwei Ausschnitte hinkopiert, einmal, wie es aussehen sollte. Und dann, wie so etwas falsch abgespeichert aussieht.

Leider habe ich nicht geschafft, den Fehler zu reproduzieren.
Eine Gruppe hatte beispielsweise die letzte Datei unter einem neuen Namen im Date-Ordner (xx_data) abgespeichert. Mache ich das bei anderen, wird es jedoch korrekt gespeichert. Daran kann es so nicht liegen.
Bei einer Gruppe weiß ich noch, dass vor dem Speichern Audacity gesponnen hat, d. h. man konnte nichts mehr hören - und "Anders speichern" (z. B. als WAVE) ging auch nicht, als wenn Audacity während der Arbeit plötzlich die Files "vergessen" hat. Das würde erklären, warum sie auch in der AUP-Datei fehlen. Andere betroffene Schüler sagten wiederum, dass bei ihnen vor dem letzten Abspeichern alles lief.

Wie gesagt, der Fehler schlägt unvermittelt zu. Bei zwei Laptops trat der Fehler heute zum ersten Mal auf, sonst gab es keine Probleme.

_____________________________
SO sollte es aussehen:
<?xml version="1.0" standalone="no" ?>
<!DOCTYPE project PUBLIC "-//audacityproject-1.3.0//DTD//EN" "http://audacity.sourceforge.net/xml/audacityproject-1.3.0.…" >
<project xmlns="http://audacity.sourceforge.net/xml/" projname="8b Marcel und Lee-Ann_data" version="1.3.0" audacityversion="2.2.0" sel0="2.9721541950" sel1="2.9721541950" vpos="16" h="3.6223129252" zoom="86.1328125000" rate="44100.0" snapto="off" selectionformat="hh:mm:ss + Millisekunden" frequencyformat="Hz" bandwidthformat="Oktaven">
    <tags/>
    <wavetrack name="Tonspur" channel="2" linked="0" mute="0" solo="0" height="150" minimized="0" isSelected="0" rate="44100" gain="6.309574" pan="-1.0">
        <waveclip offset="0.00000000">
            <sequence maxsamples="262144" sampleformat="262159" numsamples="148992">
                <waveblock start="0">
                    <simpleblockfile filename="e0000bf2.au" len="148992" min="-0.117493" max="0.142548" rms="0.019904"/>
                </waveblock>
            </sequence>
            <envelope numpoints="0"/>
        </waveclip>
        <waveclip offset="5.25000000">
            <sequence maxsamples="262144" sampleformat="262159" numsamples="93696">
                <waveblock start="0">
                    <simpleblockfile filename="e000046c.au" len="93696" min="-0.089661" max="0.106689" rms="0.015594"/>
                </waveblock>
            </sequence>
            <envelope numpoints="0"/>
        </waveclip>
        <waveclip offset="8.77011338">
            <sequence maxsamples="262144" sampleformat="262159" numsamples="112741">
                <waveblock start="0">
                    <simpleblockfile filename="e0000e77.au" len="112741" min="-0.139404" max="0.16153" rms="0.019833"/>
                </waveblock>
            </sequence>
            <envelope numpoints="0"/>
        </waveclip>
        <waveclip offset="12.45276644">
            <sequence maxsamples="262144" sampleformat="262159" numsamples="75776">
                <waveblock start="0">
                    <simpleblockfile filename="e0000cd1.au" len="75776" min="-0.090179" max="0.079681" rms="0.01264"/>
                </waveblock>
            </sequence>
            <envelope numpoints="0"/>
        </waveclip>
    </wavetrack>   


____________________________________
So sah es bei der kaputten Datei aus:
<?xml version="1.0" standalone="no" ?>
<!DOCTYPE project PUBLIC "-//audacityproject-1.3.0//DTD//EN" "http://audacity.sourceforge.net/xml/audacityproject-1.3.0.…" >
<project xmlns="http://audacity.sourceforge.net/xml/" projname="123_data" version="1.3.0" audacityversion="2.2.0" sel0="26.3758867610" sel1="26.3758867610" vpos="0" h="0.0000000000" zoom="40.7948369565" rate="44100.0" snapto="off" selectionformat="hh:mm:ss + Millisekunden" frequencyformat="Hz" bandwidthformat="Oktaven">
    <tags/>
    <wavetrack name="e0000bf2" channel="2" linked="0" mute="0" solo="0" height="156" minimized="0" isSelected="1" rate="44100" gain="17.782795" pan="0.0">
        <waveclip offset="2.67029478">
            <sequence maxsamples="262144" sampleformat="262159" numsamples="148992">
                <waveblock start="0">
                    <simpleblockfile filename="" len="148992" min="-0.117493" max="0.142548" rms="0.019904"/>
                </waveblock>
            </sequence>
            <envelope numpoints="0"/>
        </waveclip>
        <waveclip offset="10.43965986">
            <sequence maxsamples="262144" sampleformat="262159" numsamples="148992">
                <waveblock start="0">
                    <simpleblockfile filename="" len="148992" min="-0.117493" max="0.142548" rms="0.019904"/>
                </waveblock>
            </sequence>
            <envelope numpoints="0"/>
        </waveclip>
        <waveclip offset="15.62229025">
            <sequence maxsamples="262144" sampleformat="262159" numsamples="148992">
                <waveblock start="0">
                    <simpleblockfile filename="" len="148992" min="-0.117493" max="0.142548" rms="0.019904"/>
                </waveblock>
            </sequence>
            <envelope numpoints="0"/>
        </waveclip>
        <waveclip offset="19.30494331">
            <sequence maxsamples="262144" sampleformat="262159" numsamples="148992">
                <waveblock start="0">
                    <simpleblockfile filename="" len="148992" min="-0.117493" max="0.142548" rms="0.019904"/>
                </waveblock>
            </sequence>
            <envelope numpoints="0"/>
        </waveclip>
        <waveclip offset="24.57079365">
            <sequence maxsamples="262144" sampleformat="262159" numsamples="148992">
                <waveblock start="0">
                    <simpleblockfile filename="" len="148992" min="-0.117493" max="0.142548" rms="0.019904"/>
                </waveblock>
            </sequence>
            <envelope numpoints="0"/>
        </waveclip>
    </wavetrack>
Corner #2
Mitglied seit 01/2018 · 1 Beitrag
Gruppenmitgliedschaften: Benutzer
Profil anzeigen · Link auf diesen Beitrag
Betreff: zu deinem beitrag
hallo
das heißt als das man keine change hat die sache wieder hinzubekommen, sprich die verlorenen daten zu rekonstruieren.
vg alex
Schließen Kleiner – Größer + Auf diesen Beitrag antworten:
Prüfcode: VeriCode Gib bitte das Wort aus dem Bild ins folgende Textfeld ein. (Nur die Buchstaben eingeben, Kleinschreibung ist in Ordnung.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Weitere Zeichen:
Gehe zu Forum
This board is powered by the Unclassified NewsBoard software, 20120620-dev, © 2003-2011 by Yves Goergen
Aktuelle Zeit: 20.07.2018, 03:07:33 (UTC +02:00)