Schwerer Ausnahme Fehler

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Schwerer Ausnahme Fehler

      Hi

      Erstmal ein dickes Lob ihr habe da was ganz tolles auf die beine gestellt. Das ist bis jetzt das beste Soundbearbeitungsprogram was ich auf meinem Rechner hatte. Weiter so !!!

      Nun zu dem Problem. Und zwar läst sich Audacity bei mir nur starten wenn ich als Administrator eingeloggt bin.
      Wenn ich mich mit nem anderen Account einlogge (komischerweise auch wenn dieser acout admin rechte hat) bekomme ich eine Speicherschutzverletzung.
      Benutze Win2000 mit Sp 4 und sämtlichen sicherheitsupdates.
      Virenscanner läuft Sophus antivirus (glaube aber nicht das der das ist)

      Mich würde mal interressieren ob sonst noch jemand von euch evtl. dieses problem feststellen kann. Und falls es wirklich an audacity liegt. Könnt ihr das ja evtl. bei der weiteren entwicklung berücksichtigen.
      Ist nämlich ein spitzen program.

      Gruss Christoph
    • Kommt die Speicherschutzverletzung schon beim Starten? Wie hast Du das Programm installiert? (ZIP-.Datei, EXE-Datei) und unter welchem Account (war's der Administrator-Account oder der User-Account?)


      Markus
      Markus -- Audacity Lead Developer / Administrator Audacity Forum
      [url=http://www.privatmusikverein.de/]Privatmusikverein Nürnberg e.V. - Veranstalter für Kammermusik-Konzerte in Nürnberg[/url]
    • Ja schon beim starten.
      Der dienst hängt hinterher noch im taskmanager und mus dann manuell beendet werden. Allerdings öffnet sich noch nicht mal ein fenster. Es kommt gleich der Ausnahmefehler.
      war mit der Exe.
      War ein user Account der aber admin rechte hat.
      (wie gesagt es läuft nur wenn ich mich dirckt als administrator einloge)

      Christoph
    • Kannst Du ausschließen, dass die Konfiguration bei dem User kaputt ist, den Du probierst? (Gegenprobe: Ganz neuen User anlegen, und Audacity starten), Alternativ Konfigurationsdateien säubern (müsste irgendwo bei "c:\dokumente und einstellungen\username\anwendungsdaten" eine audacity.ini oder .audacity-Datei geben, weiß jetzt nicht genau auswendig, was bei Windows da gemacht wird.

      Ansonsten ist es schwierig, ohne weitere Infos wie Stack-Trace/Debug-Informationen was über die Ursachen zu sagen... und um die zu generieren, bräuchtest Du eine Programmierumgebung :(


      Markus
      Markus -- Audacity Lead Developer / Administrator Audacity Forum
      [url=http://www.privatmusikverein.de/]Privatmusikverein Nürnberg e.V. - Veranstalter für Kammermusik-Konzerte in Nürnberg[/url]
    • Also die datein habe ich jetzt nicht gefunden, aber ich habe einfach mal alles gelöst was mit audacity zu tun hat und dann neu die 1.2.2 version installiert.
      Und prompt hatte ich wieder denn fehler.
      http://www.mmweg.rwth-aachen.de/~christoph.wieczorek/audacity/fehler1.bmp
      http://www.mmweg.rwth-aachen.de/~christoph.wieczorek/audacity/fehler2.bmp

      habe leider grade keine vernünftige bildbearbeitung drauf deshalb sich die files etwas grösser :( hoffe das macht dir keine Probleme, und du kannst da etwas mit anfangen, falls nicht und du weitere daten brauchst must mit sagen wie ich die dann aus Visual studio rausbekomme und dir schicken kann.

      Das etwas nicht mit dem user in Ordnung ist schliese ich eigentlich aus, da das problem ja auch schon kurz nach der neuinstallation auftrat. Sprich ich hatte neu installiert, und dann ging es auch noch nicht aber ich kann denn test auch nochmal mit nem neuen user machen.

      Es geht auch nicht wie ich herausgefunden habe wenn man audacity mit den rechten des administrators startet.
      (rechte maustaste ausführen als... (mit gedrückter shift taste))
      Sonder wirklich nur wenn man als administrator eingelogt ist.

      Gruss Christoph
    • Habe bemerkt, dass unter Windows Audacity-Infos in der Registry sind.

      HKEY_CURRENT_USER\Software\Audacity

      Lt. dem zweiten Screenshot passiert der Fehler beim Einsprung in LAME. Könntest Du es mal mit einer anderen LAME-Version probieren? Ich weiß ja nicht, wie viel Zeit Du hast und wie sehr es Dich interessiert, da Du aber offensichtlich Visual C++ installiert hast, könntest Du ja mal versuchen, Audacity als Debug-Version zu kompilieren, und dann einen Call Stack usw. zu generieren. Falls man daraus nichts lesen kann, würde ich Dir auch anbieten, mal eine "Fernwartung" mit VNC o.ä. zu machen. Ich bin mir nämlich ziemlich sicher, dass es ein leicht zu behebendes Problem ist.
      Markus -- Audacity Lead Developer / Administrator Audacity Forum
      [url=http://www.privatmusikverein.de/]Privatmusikverein Nürnberg e.V. - Veranstalter für Kammermusik-Konzerte in Nürnberg[/url]
    • Hi

      Hab den fehler beseitigen können.
      Lag wie du sagtest an lame. Nachdem ich das selbe problem mit ClipInc. Hatte hab ich mir dann meine lame verison nochmal genauer angeschaut.
      Habe wohl darmals als irgentein program lame brauchte einen fehler bei der installation/update gemacht. Nachdem ich jetzt alle datein nochmal neu ins Winnt/system32 verzeichnis kopiert hatte funktionierte es auf einmal. ;o) Müssen datein von lame gefehlt haben, oder versionsunterschiede gewesen sein.

      Danke nochmal für die hilfe.
      Manchmal lieg die lösung so nahe.

      (wenn ich im semester in info aufgepast hätte und nicht nur zur klausurvorbereitung mir den kram angeschaut hätte. Hätte ich auch früher drauf kommen können)

      Aber jetzt gehts ja *freu*

      Also danke nochmal für die hilfe. (Auch wenn es mein eigenes verschulden war.)

      Christoph