Probleme bei wxwidgets-Installation - Kompilierung klappt nicht SuSE 9.2

  • Nein, für Audacity musst Du wxGTK kompilieren, und zwar ohne Unicode-Unterstützung, und zu GTK1 lingen. Die Fehlermeldung sagt aber, er scheint nach gtk2 zu suchen.


    Prinzipiell würde ich alles selber kompilieren, und zwar nach der "CompilingAudacityForBeginners"-Anleitung im Wiki, das funktioniert auf jeden Fall und es gibt keine Probleme mit irgendwelchen RPMs aus "dubiosen Quellen" ;)

  • Also bei mir läuft das Audacity-RPM vom SuSE-ftp einwandfrei...
    Du mußt allerdings auch wxGTK-compat (RPM gibts am SuSE-ftp) installieren! Da sind nämlich die *base* usw. (ohne u) Dateien drin.


    Schöne Grüße,
    Wolfi

  • OK, danke für die Infos. Da hatte ich wohl immer die falschen wx-Dateien probiert.


    Lade nun beides nochmal runter, wie du es beschrieben hast.


    Werde es dann heut Abend mal versuchen, auf ein neues! :)

  • Jetzt muss ich mir mal selbst antworten:


    So, nun läuft alles, libid3tag brauchte er auch noch.


    Wann muss man "devel"-Dateien nehmen? Ich hab nämlich nur die ohne devel heruntergeladen.

  • Quote from Mäkuss


    Jetzt muss ich mir mal selbst antworten:


    So, nun läuft alles, libid3tag brauchte er auch noch.


    Wann muss man "devel"-Dateien nehmen? Ich hab nämlich nur die ohne devel heruntergeladen.


    Die -devel braucht du nur wenn du was kompilieren musst. Wenn du also die SuSE rpms genutzt brauchst du kein devel.