Audacity SVN HEAD unter Debian selber kompilieren

  • Debian 6 Squeeze (28. Januar 2011)


    Folgende Debian Pakete müssen installiert sein:


    * automake
    * build-essential (GCC etc.)
    * subversion (SVN)


    wxWidgets (Audacity Grafikoberfläche):


    * libwxbase2.8-x (mit "x" ist die jeweils neueste Version gemeint)
    * libwxbase2.8-dev


    GNOME:


    * libwxgtk2.8-x (mit "x" ist die jeweils neueste Version gemeint)
    * libwxgtk2.8-dev
    * libgtk2.0-x (mit "x" ist die jeweils neueste Version gemeint)
    * libgtk2.0-dev


    Habe leider keine Ahnung was für KDE gebraucht wird. Wer was weiss bitte hier reinschreiben.


    ALSA (Linux Sound):


    * libasound2 (ist meist schon installiert)
    * libasound-dev (muss noch installiert werden)


    Sonst noch:


    * zlib1g (ist meist schon installiert)
    * zlib1g-dev (muss noch installiert werden)


    "libportaudio" muss nicht undedingt installiert sein, die Audacity SVN Version hat eine eigene Kopie von portaudio dabei, die mit portmixer wahrscheinlich (hoffentlich) besser funktioniert.
    [line]
    [m]bash$ mkdir -p src/audacity
    bash$ cd src/audacity
    bash$ svn co http://audacity.googlecode.com/svn/audacity-src/trunk/ audacity-svn
    bash$ cd audacity-svn
    bash$ ./configure 2>&1 | tee configure.txt[/m]
    [line]
    "2>&1 | tee configure.txt" schreibt eine Kopie aller "./configure" Ausgaben (stdout & errout) in die Datei "configure.txt". Die "configure.txt" Datei kann danach mit einem Texteditor auf Konfigurationsfehler untersucht werden. Das geht einfacher als im Terminal nach Fehlermeldungen zu suchen.
    [line]
    [m]bash$ make
    bash$ su
    <passwort>
    bash# make install[/m]
    [line]
    Ergebnis: ich kann mit ALSA aufnehmen und wiedergeben auch die "portmixer" Ein- und Ausgangsregler in Audacity funktionieren beide.


    Diese Anleitung ist zu kurz. Wer mehr Details braucht bitte hier reinschreiben.

  • Hallo Edgar,


    hat super geklappt mit dieser Anleitung (ich verwende Debian Squeeze 64 bit), nun funktioniert auch der line-in-Regler bei der Aufnahme :)
    2 kleine Anmerkungen noch:


    1. Bei mir gibt's nur das Paket 'libasound2-dev'.
    2. Ich habe anstelle des klassischen 'make install' den Befehl 'checkinstall' verwendet (gibt's als Paket bei Debian von Felipe Sateler), da kann man das ganze besser ins System einbinden bzw. alles komplett wieder deinstallieren.


    Werde anschließend das Ganze mal mit meinem parallel installierten Ubuntu 10.04 (32bit) testen, müsste allerdings auch klappen, gebe da noch Bescheid.


    Andreas

  • Quote

    ...bei mir gibt's nur 'libasound2-dev'...


    Also bei mir gibt es "libasound2" und "libasound-dev" (ist aber 32-bit und nicht 64-bit), habe gerade nochmal nachgeschaut.


    Quote

    ...habe anstelle von 'make install' den Befehl 'checkinstall' verwendet...


    Das ist eine gute Idee, habe ich noch gar nicht ausprobiert weil ich mein Debian sowiso immer durch selbstkompilierte Fremdsoftware verhunze und "apt-..." dann sowieseo nicht mehr richtig funktioniert. Ich habe momentan aber ein Debian Squeeze System das ich nicht unbedingt zum Arbeiten brauche, da kann ich alles mögliche mal ausprobieren. :)


    Quote

    ...werde anschließend das Ganze mal mit meinem parallel installierten Ubuntu 10.04 (32bit) testen...


    Ubuntu verwendet "pulseaudio", es kann sein dass noch irgendwelche "pulse...-dev" Pakete installiert werden müssen.

  • So, habe nun auch unter Ubuntu 10.04 (32bit) audacity erfolgreich kompilieren können nach deiner Anleitung :)
    Anstelle von su und <passwort> hatte ich nach 'make' versucht die Sache mit checkinstall sauber zu installieren (mit 'sudo checkinstall'), die Paketerstellung schlug aber immer fehl wg. fehlender svn-Nr. !? :scared:
    Dann hatte ich das Ganze eben mit
    sudo make install
    installiert, egal, einmal geht das schon ;)


    Es war pulseaudio installiert, ich brauchte dazu aber keine dev-Pakete mehr installieren.
    Ich musste mich nur noch ein bischen mit den Mixereinstellungen spielen (hatte dazu kmix benutzt, musste nur noch den 'line-Eingang' aktivieren und 'capture", die Lautstärke entsprechend hoch schrubbern und schon lief die ganze Sache :)
    Bei meiner Soundkarte wurde diese unter alsa nicht als "default" erkannt, sondern unter Ensonic... (hw0,0) oder so ähnlich, ggf. einfach mehrere Optionen ausprobieren.
    Mit OSS konnte /dev/dsp nicht gefunden werden, brauche ich nun auch nicht mehr...
    Die Feinabstimmung konnte ich dann in audacity selbst vornehmen (Wiedergabe bzw. Aufnahmelautstärke).


    Andreas