Posts by misc

    Ich verwende Fedora, möchte daher zu OpenSUSE bzw. vermurksten Zugriffsrechten nix sagen. Die Ausgabe im Terminal ist aber oft hilfreich. Sowie bei Problemen mit device permissions der Vergleich, ob denn andere Audio Programme funktionieren.


    ldconfig auszuführen ist nur notwendig und sinnvoll, sofern auch tatsächlich neue Libraries in die zugehörigen Verzeichnisse (/etc/ld.so.conf*) installiert werden. Audacity installiert hier keine Libs.

    Quote from graupen


    Ich habe Audacity mit den configure-Optionen --disable-JACK_CFLAGS und disable-JACK_LIBS neu kompiliert, ohne Erfolg.


    Klar, das sind unsinnige Optionen. JACK_CFLAGS und JACK_LIBS sind Umgebungsvariablen, keine Optionen.


    JACK läßt sich nur ausschalten, indem Du die Header und pkgconfig Datei deinstallierst oder PortAudio v19 vorm Compilieren umkonfigurierst (siehe oben).


    Quote


    "killall jackd" bei laufendem Audacity hat nicht gebracht.


    Dann kill ihn halt über seine PID.

    Das hat nicht zwangsläufig etwas zu bedeuten.


    Fakt ist, auch bei Dir wird beim Starten von Audacity jackd gestartet. Solltest Du leicht prüfen können. Wie ich im anderen Thema schrieb, kannst Du den daemon auch testweise killen, nachdem Audacity gestartet ist.


    "configure" kennt bzgl. JACK noch keine Option. Allenfalls ein nachträgliches cd ./lib-src/portaudio-v19/configure --without-jack // gut möglich, daß sich das oberste configure Skript auch über $JACK_CFLAGS und $JACK_LIBS täuschen läßt, um JACK nicht zu finden. ;)


    Mensch Markus, auch hier ist eincompilierter JACK support der Knackpunkt. Bitte die 1.3.4-beta ohne JACK Unterstützung compilieren. PortAudio v19 startet irrtümlich den jack daemon und blockiert dadurch Zugriff auf ALSA etc. Siehe auch meine vorherige Antwort im anderen Thema hier im Forum.

    Quote from karl07:1195773598


    Wenn ich aber Version 1.3.4.1 verwende, kann ich zwar Mp3 Dateien importieren, aber dort bekomme ich die Meldung das sich mein Audiogerät nicht öffnen lässt, d.h. ich kann da nichts abspielen. Allerdings habe ich schon alle Audiotreiber einzeln ausprobiert, aber: kein Chance.


    Starte "audacity" mal in einem graphischen Terminal, um dort die Ausgabe sehen und kopieren zu können. 1.3.4 ist von einigen Problemen betroffen, die ganz sicher nicht nur OpenSUSE betreffen. Zumindest unter Fedora und Ubuntu gibt es derweil Bestätigungen. Es würde mich nicht wundern, wenn unter OpenSUSE auch beim Start von Audacity der "jackd" (JACK daemon) gestartet würde. Falls das der Fall ist, kannst Du ihn probeweise mit "killall jackd" beenden, während Du Audacity weiterlaufen läßt, um danach den ALSA oder OSS Treiber zu wählen.


    Ist JACK nicht das Problem, versuch mal, im Hauptfenster links unten die "Projekt-Frequenz" auf 48000 Hz zu wechseln.

    "twolame" ist für mp2, "lame" für mp3.


    rpm.livna.org stellt Fedora Pakete von Audacity mit mp3 Support bereit. Ich empfehle sie gegenüber dem Source Code, da einige Fehler behoben werden:

    http://wftp.tu-chemnitz.de/pub….2-0.4.beta.lvn6.i386.rpm


    Quote


    Jetzt werden auch die Sound-Treiber (OSS) erkannt, was in der Version von Fedora nicht der Fall war.


    Huch? Lässt sich nicht reproduzieren. ALSA und OSS gehen hier.
    Dazu bitten einen bug report: http://bugzilla.redhat.com
    Nur das hilft uns weiter.

    Das liegt an Übersetzungsfehlern (z.B. in Audacity 1.2.6), dass dem Text vermeintlich nachlame_enc.dll anstatt libmp3lame.so.0 gesucht wird. Eigentlich wird nach libmp3lame.so gesucht, was aber ungünstig ist, denn das ist nur eine Datei, die für Softwareentwicklung benötigt wird. Der zugehörige Eintrag in bugzilla ist noch unbeantwortet.

    Der 1.3.2-beta tarball hat einen Fehler, durch den libsamplerate zwar gelinkt, aber nicht genutzt wird. Dadurch ist Resampling völlig aktiviert, weil auch libresample nicht verwendet wird. Das ist fatal für Soundkarten, die unbedingt Resampling für die Wiedergabe benötigen, weil sie über die ALSA Treiber und PortAudio v19 nur wenige Standardfrequenzen anbieten. Das Resultat sind schrille, hässliche Töne.


    Ein Patch findet sich hier: http://limpet.net/audacity/bugzilla/show_bug.cgi?id=257#c1