Ruckler bei Aufnahme vom USB-Plattenspieler bei gleichzeitigem Abspielen

  • der Betreff beschreibt mein Problem ja schon.
    wenn ich nur aufnehme, ohne ohne gleichzeitig mitzuhören, also ohne software playthrough funktioniert alles prächtig.
    aber es wäre schön software playthrough nutzen zu können.


    Noch ein paar Angaben zu meinem System:


    Ashrock Board mit nvidia Chipsatz, onboard sound nvidia/realtec
    AMD Sempron64 3000 mit Debian etch
    2GB RAM, 2 sata Platten Gnome Desktop.
    Audaciti 1.3.3-beta aus den Debian-Quellen.


    beim Mixer bekomme ich 3 Geräte angezeigt:


    1. NVidia CK8S (Alsa mixer)
    2. USB Audio Codec (Alsa mixer)
    3. Realtek ALC850 rev 0 (OSS mixer)
    was mich sehr wundert, weil doch eigentlich nur ein Onboard sound habe !



    hier die sources.list


    deb http://ftp2.de.debian.org/debian/ etch main contrib non-free
    deb-src http://ftp2.de.debian.org/debian/ etch main contrib non-free


    deb http://security.debian.org/ etch/updates main contrib non-free
    deb-src http://security.debian.org/ etch/updates main contrib non-free


    deb http://www.debian-multimedia.org etch main


    deb http://ftp.de.debian.org/debian unstable main contrib non-free
    deb-src http://ftp.de.debian.org/debian unstable main contrib non-free


    deb http://kanotix.com/files/fix/vdr.feisty ./
    deb-src http://kanotix.com/files/fix/vdr.feisty ./


    habe versucht die Quellen aus dem cvs zu kompilieren, aber dort scheitere ich beim make wie folgt:


    bei configure bekomme ich folgendes:


    configure: creating ./config.status
    config.status: creating Makefile


    Finished configure:
    LIBVORBIS: using SYSTEM libraries
    LIBMAD: using SYSTEM libraries
    LIBSNDFILE: using LOCAL libraries
    LIBFLAC: using LOCAL libraries
    LIBID3TAG: using SYSTEM libraries
    LIBSAMPLERATE: disabled
    LIBRESAMPLE: using LOCAL libraries
    LIBSOUNDTOUCH: using LOCAL libraries
    LIBNYQUIST: using LOCAL libraries
    LIBEXPAT: using LOCAL libraries
    LIBTWOLAME: using LOCAL libraries
    ladspa: enabled
    audiounits: disabled
    prefix=/usr/local
    portaudio: v19


    Run 'configure --help' for an explanation of these options,
    otherwise run 'make' to build Audacity.



    die letzten Zeilen beim make sind:


    g++ -shared -nostdlib /usr/lib/gcc/i486-linux-gnu/4.1.3/../../../../lib/crti.o /usr/lib/gcc/i486-linux-gnu/4.1.3/crtbeginS.o .libs/libFLAC++.la-7.o -Wl,--rpath -Wl,/mnt/home/didi/audacity/lib-src/libflac/src/libFLAC/.libs -Wl,--rpath -Wl,/usr/local/lib ../libFLAC/.libs/libFLAC -L/usr/lib/gcc/i486-linux-gnu/4.1.3 -L/usr/lib/gcc/i486-linux-gnu/4.1.3/../../../../lib -L/lib/../lib -L/usr/lib/../lib -lstdc++ -lm -lc -lgcc_s /usr/lib/gcc/i486-linux-gnu/4.1.3/crtendS.o/usr/lib/gcc/i486-linux-gnu/4.1.3/../../../../lib/crtn.o -Wl,-soname -Wl,libFLAC++.5 -o .libs/libFLAC++.5.0.0
    g++: /usr/lib/gcc/i486-linux-gnu/4.1.3/../../../../lib/crti.o: No such file or directory
    g++: /usr/lib/gcc/i486-linux-gnu/4.1.3/crtbeginS.o: No such file or directory
    g++: /usr/lib/gcc/i486-linux-gnu/4.1.3/crtendS.o: No such file or directory
    g++: /usr/lib/gcc/i486-linux-gnu/4.1.3/../../../../lib/crtn.o: No such file or directory
    make[5]: *** [libFLAC++.la] Fehler 1
    make[5]: Leaving directory `/mnt/home/didi/audacity/lib-src/libflac/src/libFLAC++'
    make[4]: *** [all-recursive] Fehler 1
    make[4]: Leaving directory `/mnt/home/didi/audacity/lib-src/libflac/src'
    make[3]: *** [all-recursive] Fehler 1
    make[3]: Leaving directory `/mnt/home/didi/audacity/lib-src/libflac'
    make[2]: *** [all] Fehler 2
    make[2]: Leaving directory `/mnt/home/didi/audacity/lib-src/libflac'
    make[1]: *** [libflac-recursive] Fehler 2
    make[1]: Leaving directory `/mnt/home/didi/audacity/lib-src'
    make: *** [audacity] Fehler 2


    Und nun ?

  • Zunächst: unsere Erfahrungen mit USB-Plattenspielern sind, naja, "gemischt". Wir hatten hier schon einige Fälle, wo es mit USB-Plattenspieler auch unter Windows Probleme gab. Das sind dann meistens Hardware- oder Treiberprobleme, die mit Audacity nur bedingt was zu tun haben. Auch unter Linux denke ich, dass die fehlende "Duplex-Fähigkeit" (so könnte man ja Dein Problem zusammenfassen) eher am Treiber bzw. im Kernel zu suchen ist, bzw. gleich beim Mainboard oder der USB-Hardware als bei Audacity. Die vordergründig guten Specs Deines Rechners (schnell, viel RAM usw.) sind da nur bedingt ein Indikator dafür. Was bringen Dir 3 Ghz Rechenleistung, wenn die Grafikkarte regelmäßig den PCI-Bus für längere Zeit sperrt und dadurch Daten von der Soundkarte (zu lange) warten müssen und verloren gehen? Weiterhin wird es wahrscheinlich so sein, dass der Hersteller des USB-Plattenspielers sicher keinen Support für den Einsatz unter Linux geben wird, also gibt es keine Veranlassung, sich darauf zu verlassen, dass es überhaupt funktioniert. Insofern empfehle ich unter Linux immer den Einsatz garantiert kompatibler Hardware, wozu die USB-Plattenspieler nun mal nicht gehören.


    Zu Deinem "Full-Duplex-Problem" allgemein: es gibt auch unter Linux Programme, die den ganzen grafischen Schnickschnack von Audacity nicht haben und deshalb bei der Aufnahme evtl. mehr Rechenzeit dazu verwenden können, Daten einzulesen. Das könntest Du mal probieren (die Aufnahmen kannst Du immer noch mit Audacity nachbearbeiten). Du kannst auch einfach in den Audacity-Einstellungen die Latenzzeit hochstellen (bei Audio E/A), das hilft oft bei Rucklern, macht das Programm aber träger. Außerdem verschiedene Kombinationen von ALSA/OSS für Wiedergabe/Aufnahme ausprobieren.


    Zum Kompilierproblem: Du hast ja einen 64-bit-Rechner, und dafür ist Audacity nicht ausgelegt. Es scheint so zu sein, dass Du Audacity mit einem 64-bit-Compiler kompilierst, aber der Linker versucht in 32 bit zu linken oder so was ähnliches. Oder es werden Teile mit 64-bit und Teile mit 32-bit-Unterstützung kompiliert. Ich empfehle, Audacity mit 32 bit zu kompilieren, da wir 64 bit noch nie getestet haben, auch wenn es Leute gibt, die sagen, sie hätten Audacity unter 64-bit-SUSE erfolgreich im 64-bit-Modus kompiliert. Wie man das bei Debian macht (auf 32-bit-Kompiliermodus umstellen): keine Ahnung.

  • Ersteinmal danke für Deine Erklärungen. Da ich den Plattenspieler auch über kabel an die Line-In Buchse der Soundkarte betreiben kann, werde ich das auch mal probieren, sobald ich ein chinch-Buchse zu Klinke Kabel gebastelt/gekauft habe.


    Ich hab auf dem Rechner auch Ubuntustudio installiert, (i386) kein 64 bit,
    dort läuft das make durch, allerdings crasht das Programm dann sobald ich was ernsthaftes zu machen beabsichtige. dort wurde wx in Version 2.8 installiert, wohingegen bei Debian etch (ist überigens auch 32-bittig installiert) die Version 2.6 aus den Quellen installiert wird.


    kann es sein, das ich trotz installiertem 32 bit system beim compilieren einen Parameter für 32bit setzen muss? wie würde der dann heissen ?


    Zu Deinem Beispiel mit der Grafikkarte: hab ne Nvidia 6200 . Ist Deiner Meinung nach der Treiber von nvidia oder der opensource nv treiber vorzuziehen bezüglich des audacity bzw. USB-Kernelmodul problems?


    wenn ich das software playthrough eingeschaltet habe, muss ich als wiedergabegerät alsa-default nehmen, sonst startet die Aufnahme gar nicht erst, und meint mit der saplerate würd was nicht passen.


    mit deaktiviertem playthrough geht alles prima, kann man auch mit leben, wenn es muss.

  • Zu Deinen Fragen muss ich im wesentlichen passen. Du solltest einfach probieren, was am Besten läuft (z.B. was den Treiber angeht). Das Ganze war auch nur ein Beispiel, das ich so auch schon erlebt habe. Ansonsten denke ich wie gesagt, dass das Ganze eher ein Kernel/Treiberproblem ist.

  • Quote


    kann es sein, das ich trotz installiertem 32 bit system beim compilieren einen Parameter für 32bit setzen muss? wie würde der dann heissen ?


    weiss ich auswendig auch nicht, aber hast Du schon einmal './configure --help' gefragt ?


    Nvidia: die Ubuntus sind normalerweise ziemlich schnell mit dem Treiber-Update, ich hatte aber tatsächlich mal einen Fall (weiss leider den genauen Typ der Grafikkarte nicht mehr) wo es erst funktioniert hat, nachdem ich den Open Source Treiber von http://www.nvidia.com selbst kompiliert hatte. Was auch wichtig ist, ist den Anhang im Manual des Nvidia Treibers mit den Einstellungen für die 'etc/X11/xorg.conf' zu lesen. Damit liessen sich die meisten Nvidia Probleme bisher lösen.