audacity startet mit Fehlermeldung - Expression 'snd_config_update()' failed in 'src/hostapi/alsa/p...

  • Hallo liebe Fachleute!
    Unter SUSE 10.2 habe ich per smart die erforderlichen Pakete anstandslos installieren können, gebe ich jedoch auf einer Konsole audacity & ein, bekomme ich folgende Fehlermeldung:


    Expression 'snd_config_update()' failed in 'src/hostapi/alsa/pa_
    linux_alsa.c', line: 597
    Expression 'BuildDeviceList( alsaHostApi )' failed in 'src/hostapi/alsa/pa_linux
    _alsa.c', line: 251


    (audacity:6671): Gtk-CRITICAL **: gtk_label_set_text_with_mnemonic: assertion `s
    tr != NULL' failed


    Audacity
    öffnet sich wohl; eine Datei öffnen ist jedoch nicht möglich!?


    Für Eurer Bemühen bedankt sich ein Linux-Anfänger!


    Gruß micha

  • Bei den Meldungen handelt es sich lediglich um Warnmeldungen, diese können erstmal ignoriert werden (Du würdest die auch nicht sehen, wenn Du Audacity per Icon starten würdest).


    Was passiert denn genau, wenn Du eine Datei öffnest (und welche Art von Datei ist es genau)?

  • Hallo, ich habe genaudasselbe Problem: Expression 'ValidateParameters( outputParameters, outputDeviceInfo, StreamMode_Out )' failed in 'src/hostapi/oss/pa_unix_oss.c', line: 120 Was meinst Du eigentlich mit "Dateien öffnen"? Ich habe mal audacity mit root gestartet, da kommt gleich diese Meldung. Ich habe eine Audio-Datei mit Audacity importiert, mp3, es passiert nichts. Da kommt die Meldung: Fehler beim Öffnen des Audiogeräts. Bitte prüfen sie die Einstellungen für das Audiogerät und die im Projekt eingestellte Abtastrate (Samplefrequenz). Bei der Aufnahme kommt die gleiche Meldung, bloß in Englisch. Könnt Ihr mir dabei weiterhelfen? Danke. Gruß Annelie

  • Ich möchte nicht unhöflich sein, kannst Du mir sagen, in welchem Thread Du mir geschrieben hast. Das Ganze verwirrt mich jetzt ein wenig. Ich finde Deinen Beitrag einfach nirgens. Wonach muß ich suchen, um Deinen Beitrag zu finden? Bei beiden Themen schreibst Du das Gleiche und wo nun ist Dein Beitrag für mich geblieben? Ich weiß es einfach nicht. Gruß Annelie

  • Ich hatte geschrieben:


    Quote


    Mögliche Lösungsansätze für Dein Problem: http://www.audacity-forum.de/thread/1689


    Dort steht:



    In Deinem Fall tippe ich darauf, dass noch der "artsd"-Daemon von KDE gestartet ist. Um diesen zu beenden, solltest Du eine Kommandozeile öffnen und "killall artsd" eingeben. Danach sollte sich Audacity starten lassen. Es kann aber auch eines der anderen o.g. Probleme sein.


    Tipps zum Fragenstellen und "wiederfinden" gibt's übrigens hier: http://www.audacity-forum.de/thread/791